<!DOCTYPE html> <html lang="en-US"> <head> <script>var pb_global={pageName:"article-template",pageId:"r0rrvMTr7WCp9r",contextPath:"/pb",isAdmin:false,layoutEngineName:"",environment:"prod",resourceToken:"",_website:"wlbt"};</script> <script>window.serviceCallbacks=[];window.pageBuilder=window.pageBuilder||{};window.pageBuilder.featureLoaded=function(el){if(window.services.asyncFeatureCallback)window.services.asyncFeatureCallback(el);else window.serviceCallbacks.push(function(){window.services.asyncFeatureCallback(el)})};</script> <script>(function(){if(window.BOOMR&&window.BOOMR.version)return;var dom,doc,where,iframe=document.createElement("iframe"),win=window;function boomerangSaveLoadTime(e){win.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(win.addEventListener)win.addEventListener("load",boomerangSaveLoadTime,false);else if(win.attachEvent)win.attachEvent("onload",boomerangSaveLoadTime);iframe.src="javascript:false";iframe.title="";iframe.role="presentation";(iframe.frameElement||iframe).style.cssText="width:0;height:0;border:0;display:none;";
where=document.getElementsByTagName("script")[0];where.parentNode.insertBefore(iframe,where);try{doc=iframe.contentWindow.document}catch(e){dom=document.domain;iframe.src="javascript:var d\x3ddocument.open();d.domain\x3d'"+dom+"';void(0);";doc=iframe.contentWindow.document}doc.open()._l=function(){var js=this.createElement("script");if(dom)this.domain=dom;js.id="boomr-if-as";js.src="https://c.go-mpulse.net/boomerang/"+"XPXCW-DAMJV-5VCNY-NSGAA-ZZ4G2";BOOMR_lstart=(new Date).getTime();this.body.appendChild(js)};
doc.write('\x3cbody onload\x3d"document._l();"\x3e');doc.close()})();</script> <script>
  const addZeroPad = function(num) {
    num = Math.abs(num)
    num = num.toString()
    if (num.length === 1) {
      num = '0' + num
    }
    return num
  }

  const getTimezoneOffset = function() {
    const offset = -new Date().getTimezoneOffset() / 60
    const sign = offset < 0 ? '-' : '+'
    return sign + addZeroPad(offset) + ':00'
  }
</script> <script>
  var RCdataLayer = [{
    "adTarget": "wlbt/web/news",
    "authors": [
                  
                    {
                      "_id": "howard-ballou",
                      "name": "Howard Ballou",
                      "type": "author"
                    },
                  
                ],
    "canonicalUrl": "/2018/11/15/being-good-samaritan-highway-could-be-dangerous-even-deadly/",
    "contentId": "G2DIWSE7HBB6DEQBFC5MRBF7MQ",
    "contentName": "Being a “Good Samaritan” on the highway could be dangerous, even deadly",
    "contentOwner": "wlbt",
    "contentTags":  [
                  
                    {
                      "text": "traffic accident",
                      "description": "traffic accident",
                      "slug": "traffic-accident"
                    },
                  
                    {
                      "text": "dangerous",
                      "description": "dangerous",
                      "slug": "dangerous"
                    },
                  
                ],
    "contentType": "story",
    "datePublished": "2018-11-15T04:40:44.930Z",
    "description": "You see a traffic accident, maybe someone is injured; you want to stop and help. It's human nature, but doing so can be dangerous -- even deadly.",
    "hasVideo": "false",
    "metaDescription": "You see a traffic accident, maybe someone is injured; you want to stop and help. It's human nature, but doing so can be dangerous -- even deadly.",
    "platformName": "Arc Feature Pack",
    "primarySection": 
                        
                        
                          
                          {
                            "name": "News",
                            "_id": "/news",
                            "path": "/news",
                          }
                        
                      ,
    "publishedDay": "14",
    "publishedMonth": "11",
    "publishedYear": "2018",
    "stationName": "wlbt",
    "timezoneOffset": getTimezoneOffset(),
    "userAgent": navigator.userAgent,
    "userId": "",
    "userTimezone": Intl.DateTimeFormat().resolvedOptions().timeZone,
    "userTimezoneTimestamp": new Date()
  }]

</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!="dataLayer"?"\x26l\x3d"+l:"";j.async=true;j.src="https://www.googletagmanager.com/gtm.js?id\x3d"+i+dl;f.parentNode.insertBefore(j,f)})(window,document,"script","RCdataLayer","GTM-M5QQ3JP");</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta name="distribution" content="global"/> <meta name="rating" content="general"/> <meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"> <meta charset="UTF-8"/> <meta name="copyright" content="Copyright (c) 2017 "/> <meta name="google-site-verification" content="mTPDOSe7QkGwI3aP_QdG0WsutpFhNO_yXWg1UaPvyIs"/> <title>Being a “Good Samaritan” on the highway could be dangerous, even deadly</title> <meta name="keywords" content="Kervin Stewart, Stan Black"> <meta name="news_keywords" content="Kervin Stewart, Stan Black"/> <meta name="date" content="2018-11-15T04:40:47.016Z"/> <meta itemprop="description" name="description" content="You see a traffic accident, maybe someone is injured; you want to stop and help. It's human nature, but doing so can be dangerous -- even deadly."/> <meta name="robots" content="index,follow,noarchive"/> <meta name="googlebot" content="index"/> <meta name="googlebot-news" content="index"/> <link rel="canonical" href="/2018/11/15/being-good-samaritan-highway-could-be-dangerous-even-deadly/"> <meta name="twitter:title" content="Being a “Good Samaritan” on the highway could be dangerous, even deadly"/> <meta name="twitter:image" content="http://www.wlbt.com/resizer/aCGJEA_aMrZ1cehI2nL7HswOTEk=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/CLVDAJI7JJHHTNTZ4TE2WV5T44.PNG"/> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:description" content="You see a traffic accident, maybe someone is injured; you want to stop and help. It's human nature, but doing so can be dangerous -- even deadly."/> <meta name="twitter:site" content="@WLBT"/> <meta name="twitter:creator" content="@WLBT"> <meta property="og:url" content="/2018/11/15/being-good-samaritan-highway-could-be-dangerous-even-deadly/"/> <meta property="og:title" content="Being a “Good Samaritan” on the highway could be dangerous, even deadly"/> <meta itemprop="image" property="og:image" content="http://www.wlbt.com/resizer/aCGJEA_aMrZ1cehI2nL7HswOTEk=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/CLVDAJI7JJHHTNTZ4TE2WV5T44.PNG"/> <meta property="og:description" content="You see a traffic accident, maybe someone is injured; you want to stop and help. It's human nature, but doing so can be dangerous -- even deadly."/> <meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="http://www.wlbt.com"/> <meta property="og:type" content="article"/> <meta property="fb:app_id" content="145506258872710"/> <meta property="fb:pages" content="54813120652"/> <meta property="fb:admins" content="644426401"/> <meta property="article:publisher" content="https://www.facebook.com/WLBT3"> <meta property="article:tag" content="traffic accident, dangerous"> <link rel="amphtml" href="/2018/11/15/being-good-samaritan-highway-could-be-dangerous-even-deadly/?outputType=amp"> <meta name="author" content="Howard Ballou"> <script data-schema="NewsArticle" type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": ""
        },
        "headline": "Being a “Good Samaritan” on the highway could be dangerous, even deadly",
        
        "image": {
          "@type": "ImageObject",
          "url": "http://www.wlbt.com/resizer/aCGJEA_aMrZ1cehI2nL7HswOTEk=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/CLVDAJI7JJHHTNTZ4TE2WV5T44.PNG",
          "height": 203.0,
          "width": 1200
        },
        
        "datePublished": "2018-11-15T04:59:22.581Z",
        "dateModified": "2018-11-15T04:40:47.016Z",
        "articleBody": "Being a “Good Samaritan” on the highway could be dangerous, even deadlyCOPIAH COUNTY, MS (WLBT) -You see a traffic accident and maybe someone is injured. You want to stop and help. It’s human nature, but doing so can be dangerous -- even deadly.Case in point, on Monday, a Louisiana teacher died at the scene of a crash on I-55 in Copiah County.She was struck by an 18-wheeler after stopping to help the driver of a car involved in the accident.Back in August, former Mississippi State All-American, Stan Black of Madison, was killed after he stopped at the scene of a crash on I-55 north of the Canton exit.Black got out of his car to help the passenger of an SUV involved in the wreck and move sheet rock from the interstate.A woman driving a Kia could not stop her car in time and slammed into Black, killing him.“Well, of course, people want to help, but you know, your safety when you want to help is pretty much your first priority,&#034; said Cpl. Kervin Stewart with the Mississippi Highway Patrol. “You know, you can’t help anybody if you’re hurt, but if you do that, take all the safety precautions you can. Pull over safely out the roadway, be aware of your surroundings, but also be aware that a lot of people probably aren’t paying attention to what’s going on ahead of them and you just have to watch out for them also.”Cpl. Stewart said the holiday season will bring on even greater challenges on the highways. Thanksgiving, he said, is the most traveled period in America and he urges all drivers to be extra cautious.“Wear your safety belt. Don’t drink and drive. If you’re going to drink, have a designated driver,&#034; reminded Cpl. Stewart. &#034;I mean, it’s that time of year again where people are gonna be celebrating and, of course, if you’re gonna be out celebrating, you know, just make sure you have some safety plans in place. There’re plenty of applications on your phone you can use now to get you to and from your location, plus make sure you have a designated driver.”As for stopping at the scene of an accident to help, in some cases, it may be better to keep moving and let first responders do what they’re trained to do rather than risk even more tragedy.Copyright 2018 WLBT. All rights reserved.",
        "author": [
          
            
              
                {
                  "@type": "Person",
                  "name": "Howard Ballou"
                }
              
            
            
          
        ],
         "publisher": {
        "@type": "Organization",
        "name": "",
        "logo": {
          "@type": "ImageObject",
          "url": "http://www./pb/resources/images//logo_meta.png?token=123",
          "width": 467,
          "height": 60
        }
      }
        },
        // will be empty for branded publishing
        "description": "You see a traffic accident, maybe someone is injured; you want to stop and help. It's human nature, but doing so can be dangerous -- even deadly."
      }
    </script> <script data-schema="Organization" type="application/ld+json">
      {
        "name": "",
        "url": "http://www.wlbt.com",
        "logo": "http://www.wlbt.com/pb/resources/images/rm_icons/wlbt-icon.png?token=123",
        "@type": "Organization",
        
          "sameAs": [ "https://www.facebook.com/WLBT3" ],
        
        "@context": "http://schema.org"
      }
    </script> <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous"> <link href="https://fonts.googleapis.com/css?family=Oswald:400,600,700|PT+Serif:400,400i,700i" rel="stylesheet"> <link href="/pb/resources/dist/d404f83286001ac73b19/rm/rm-frameworkd404f83286001ac73b19.css?v=36" rel="stylesheet"/> <style>.logo{background-image:url(/pb/resources/images/wlbt-logo.svg?v=36)}</style> <link href="/pb/resources/dist/d404f83286001ac73b19/rm/rm-frameworkd404f83286001ac73b19.css?v=36" rel="stylesheet"/> <link href="/pb/resources/dist/d404f83286001ac73b19/rm/rm-featuresd404f83286001ac73b19.css?v=36" rel="stylesheet"/> <link href="/pb/resources/dist/d404f83286001ac73b19/rm/rm-servicesd404f83286001ac73b19.css?v=36" rel="stylesheet"/> <script async src="/pb/resources/dist/d404f83286001ac73b19/rm/rm-indexd404f83286001ac73b19.js?v=36"></script> <script src="/pb/gr/c/default/r0rrvMTr7WCp9r/arcAdsJS/84612eb819.js?v=36"></script> <script>
  const arcAds = new ArcAds({
    dfp: {
      id: '63316753'
    }
  });
  window.arcAds = arcAds;
</script> </head> <body> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> </head> <body> <div id="pb-root" class=""><a class="skip-link" href="#header">Skip to content</a> <section id="nav" class="relative zindex-higher col"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-sales-nav" id="fNvIO82s7WCp9r"> <div id="sales-nav" class="background-grey-minimal visible-lg"> <div class="container"> <ul class="list-unstyled flex-container-row padded padded-top padded-bottom padded-xs"> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.mississippiweekend.com/deals/" class="color-grey-dark">Mississippi Weekend Deals</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.wlbt.com/business/legal/lawcall" class="color-grey-dark">LawCall</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.facebook.com/WLBT3?ref=aymt_homepage_panel" class="color-grey-dark">Facebook</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://twitter.com/wlbt" class="color-grey-dark">Twitter</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://careers-raycommedia.icims.com/jobs/intro?hashed=-435772224&mobile=false&width=1468&height=500&bga=true&needsRedirect=false&jan1offset=-360&jun1offset=-300" class="color-grey-dark">Jobs</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://miskelly-season-of-giving.pgtb.me/c9LZdx" class="color-grey-dark">Miskelly's Season of Giving</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.wlbt.com/health/baby-faces/" class="color-grey-dark">Baby Faces</a></li> </ul> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" id="f5REg52s7WCp9r"> <style>.pb-f-article-body .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 200px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}.pb-f-article-body .card .img-container.width-full,.pb-f-article-header .card .img-container.width-full{background-color:#f9f9f9}.pb-f-article-header .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 150px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}</style> </div> <div class="pb-container"> </div> </section> <header id="sticky-nav" class="sticky zindex-higher col"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-navigation-bar" id="fRfYK81s7WCp9r"> <div id="app-bar" class="app-bar card padded padded-sm padded-top padded-bottom width-full" role="navigation"> <div class="justify-space-between align-items-center flex-container-row relative app-bar-inner container"> <button id="app-bar-topics-button" name="topicsMenu" class="app-button justify-center flex-container-row no-border" data-role="open-tray" data-tray="topics"> <span class="fa fa-2x fa-bars" aria-hidden="true"></span> </button> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="http://www.wlbt.com"> <div class="logo logo-slim"></div> </a> </div> <div class="app-bar-top-container flex-3 flex-container-row spaced spaced-sm spaced-left spaced-right hidden-sm"> <ul id="app-bar-top-menu" class="list-unstyled flex-container-row topics-list uppercase align-items-center flex-shrink"> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/homepage" class="">Home</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.wlbt.com/live" class="">Watch Live</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news" class="">News</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather" class="">Weather</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/sports" class="">Sports</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/contests" class="">Contests</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.wlbt.com/programming/schedule" class="">What's On TV</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.wlbt.com/about-us/contact/" class="">About Us</a> </h3> </li> </ul> </div> <div class="search-box-container search-box flex flex-container-row align-items-center justify-end"> <div class="search-box-inner"> <form class="search search-expandable-form small" action="/search/" method="GET"> <input type="checkbox" class="checkbox" name="search-action" id="search-action"/> <label class="magnifying-glass" for="search-action"> <i class="search-button fa fa-search"></i> <i class="close-button fa fa-times"></i> </label> <input type="text" class="search-text-field" id="expandable-search" name="q" placeholder="Search..."/> </form> </div> </div> </div> </div> <div data-role="tray" data-tray="topics"> <nav [class]="visible == true ? 'tray left-0 hidden width-full zindex-high tray-open visible' : 'tray left-0 hidden width-full zindex-high hidden'" class="tray left-0 hidden width-full zindex-high"> <div class="topics-tray tray-contents card card-dark padded padded-bottom padded-md"> <div class="tray-contents-inner container" tabindex="0"> <div class="five-hundred-screen-height"> <div class="container"> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/homepage" class="color-white">Home</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.wlbt.com/live" class="color-white">Watch Live</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="http://www.wlbt.com/apps" class="color-white">Download the WLBT Apps</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/news" class="color-white">News</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/news/investigate" class="color-white">Investigate</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/news/crime" class="color-white">Crime</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/news/crime/jackson-homicides" class="color-white">Jackson Homicides</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/news/bridge-closures" class="color-white">Bridge Closures</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/news/consumer" class="color-white">Consumer</a> </li> <li class="list-unstyled padded padded-sm padded-right li-8"> <a href="/news/editorial" class="color-white">Consider This</a> </li> <li class="list-unstyled padded padded-sm padded-right li-9"> <a href="/traffic/gas-prices" class="color-white">Gas Prices</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/weather" class="color-white">Weather</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/weather/blog" class="color-white">Weather Blog</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/weather/cams" class="color-white">Skycams</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/weather/closings" class="color-white">Closings</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="http://www.wlbt.com/weather/school-visits/" class="color-white">Request a First Alert Weather School Visit</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/sports" class="color-white">Sports</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/sports/high-school/football" class="color-white">The End Zone</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/sports/fox-40-sportsdeck" class="color-white">Fox 40 SportsDeck</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="http://www.wlbt.com/sports/scoreboard" class="color-white">Scoreboard</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/sports/ncaa/mississippi-state" class="color-white">Mississippi State</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/sports/ncaa/ole-miss" class="color-white">Ole Miss</a> </li> <li class="list-unstyled padded padded-sm padded-right li-8"> <a href="/sports/ncaa/southern-miss" class="color-white">Southern Miss</a> </li> <li class="list-unstyled padded padded-sm padded-right li-9"> <a href="/sports/ncaa/swac" class="color-white">SWAC</a> </li> <li class="list-unstyled padded padded-sm padded-right li-10"> <a href="/sports/nfl/saints" class="color-white">Saints</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/health" class="color-white">Health</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/health/baby-faces" class="color-white">Baby Faces</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/health/national" class="color-white">Health News</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/community" class="color-white">Community</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/community/fox40-feedback" class="color-white">Fox40 Feedback</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/community/3-on-the-road" class="color-white">3 On The Road</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/community/calendar" class="color-white">Calendar</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/community/user-content" class="color-white">Pics</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/contests" class="color-white">Contests</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.wlbt.com/2018/09/05/weekend-bluffs/" class="color-white">Weekend on the Bluffs</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/programming" class="color-white">Programming</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/programming/schedule" class="color-white">Schedule</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="http://www.wlbt.com/programming/me-time" class="color-white">Me Time With Frangela</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/about-us" class="color-white">About Us</a> </h3> </li> </ul> </div> </div> </div> </div> </nav> </div> </div> </div> </header> <section id="top" class="width-full"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-breaking-news" id="f0X0l7Ps7WCp9r"> <div id="breaking-news-wrapper" class="breaking-news-wrapper" data-feature-name="breaking-news-bar" data-feature-grouping=".pb-f-global-breaking-news" data-page-uri="/fragment-wlbt-breaking/" data-url="/pb/api/v2/render/feature" data-website="wlbt" data-view-unpublished=""> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-weather-weather-alerts" id="fKSiD82s7WCp9r"> <div id="weather-alerts-wrapper" class="weather-alerts-wrapper" data-feature-name="weather-alerts-bar" data-feature-grouping=".pb-f-weather-weather-alerts" data-page-uri="/wlbt-weather-alerts/" data-url="/pb/api/v2/render/feature" data-website="wlbt"> <div data-href="/pb/api/v2/render/feature"> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fvqScP1s7WCp9r"> <div id="ad331-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad331" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad331",slotName:"wlbt/web/news",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"G2DIWSE7HBB6DEQBFC5MRBF7MQ"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> </div> </section> <div class="container flex-grid"> <article id="content-well" class="col desktop-8 tablet-12 mobile-12"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-article-header" id="fN62IT1s7WCp9r"> <div class="card spaced card-article width-full spaced-bottom spaced-xs"> <div class="text-align-left card-content"> <ul class="tag-list-wrapper list-unstyled flex-container-row text-align-left uppercase unstyled-link spaced spaced-top spaced-sm call-to-action bold"> </ul> <h1 class="spaced spaced-xs spaced-top spaced-bottom">Being a “Good Samaritan” on the highway could be dangerous, even deadly</h1> <h2 class="spaced spaced-xs spaced-top">“You know, you can’t help anybody if you’re hurt, but if you do that, take all the safety precautions you can."</h2> </div> <div class="spaced spaced-top spaced-sm"> <div class="card-content"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-article-goldfish-video" id=""> <div class="video"> <div class="goldfish-video" data-video-id="powa-1358-eaae2401-e189-41c5-881d-11baba91bf21" data-script-path="d3mo2m0b34ee8e" data-environment="prod"></div> <div class="goldfish-player" data-page-on="1" data-producer=""> <div class="powa" id="powa-1358-eaae2401-e189-41c5-881d-11baba91bf21" data-ping-rate="15" data-org="raycom" data-uuid="eaae2401-e189-41c5-881d-11baba91bf21" data-playthrough="true" data-autoplay="true" data-preroll-ad-path="63316753/wlbt/web/news" data-ads="true"></div> </div> <figcaption class="caption-text spaced spaced-top spaced-xs flex-container-row justify-space-between"> <div>VIDEO: Being a “Good Samaritan” on the highway could be dangerous, even deadly</div> </figcaption> </div> </div> </div> </div> </div> </div> <div class="flex-grid flex-container-row flex-mobile-column col col-no-side-gutter pb-layout-item pb-chain pb-c-article-double-chain full" id="c0HDvH2s7WCp9r"> <section id="article-sharebar" class="col col-no-gutter desktop-1 visible-lg spaced spaced-top spaced-sm"> <div class="flex flex-container-row sticky"> <span class="sharebar app-bar-share flex-container-column text-align-right"> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" aria-label="share on twitter" name="twitter" onclick="window.open( 'https://twitter.com/intent/tweet?text=Being+a+%E2%80%9CGood+Samaritan%E2%80%9D+on+the+highway+could+be+dangerous%2C+even+deadly&amp;url=http%3A%2F%2Fwww.wlbt.com%2F2018%2F11%2F15%2Fbeing-good-samaritan-highway-could-be-dangerous-even-deadly%2F', 'share_popup', 'height=500,width=650' ); return false;" role="button" data-arctrack="socialShareTwtr" data-referrer="" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter icon-light"></i> </button> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" name="facebook" aria-label="share on facebook" onclick="window.open( 'https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.wlbt.com%2F2018%2F11%2F15%2Fbeing-good-samaritan-highway-could-be-dangerous-even-deadly%2F&amp;title=Being+a+%E2%80%9CGood+Samaritan%E2%80%9D+on+the+highway+could+be+dangerous%2C+even+deadly', 'share_popup', 'height=500,width=650' ); return false;" data-arctrack="socialShareFb" data-referrer="" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square icon-light"></i> </button> <a href="mailto:?subject=Being%20a%20%E2%80%9CGood%20Samaritan%E2%80%9D%20on%20the%20highway%20could%20be%20dangerous%2C%20even%20deadly&amp;body=Read%20more%20on%20Being%20a%20%E2%80%9CGood%20Samaritan%E2%80%9D%20on%20the%20highway%20could%20be%20dangerous%2C%20even%20deadly%20at%20http%3A%2F%2Fwww.wlbt.com%2F2018%2F11%2F15%2Fbeing-good-samaritan-highway-could-be-dangerous-even-deadly%2F"> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" role="button" aria-label="share story via email" data-arctrack="socialShareEmail" data-referrer="" rel="noopener noreferrer"> <i class="far fa-envelope icon-light"></i> </button> </a> </span> </div> </section> <section class="col col-no-gutter desktop-11 tablet-12 mobile-12 spaced spaced-top spaced-sm"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-byline" id="f4d0B72s7WCp9r"> <div class="card"> <div class="byline spaced spaced-bottom spaced-md card-content display-inline"> By <a class="color-blue hover-link" href="/authors/howard-ballou/"> <span class="font-bold ">Howard Ballou</span></a> <span class="font-bold">|</span> <span class="timestamp"> November 14, 2018 at 10:40 PM CST - Updated November 14 at 10:59 PM </span> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-body" id="f20gnB1s7WCp9r"> <div class="collection collection-cards" id="article-body"> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>COPIAH COUNTY, MS (WLBT) -You see a traffic accident and maybe someone is injured. You want to stop and help. It’s human nature, but doing so can be dangerous -- even deadly.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Case in point, on Monday, a Louisiana teacher died at the scene of a crash on I-55 in Copiah County.</p> </div> </div> <div data-type="interstitial_link" class="card collection-item card-embedded-content"> <div class="card-content card-article"> <div class="element element-interstitial"> <p>[ <a href="http://www.wlbt.com/2018/11/13/baton-rouge-high-teacher-dies-attempting-assist-crash-mississippi-roadway/"> Baton Rouge High teacher dies attempting to assist in crash on Mississippi roadway</a> ] </p> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>She was struck by an 18-wheeler after stopping to help the driver of a car involved in the accident.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Back in August, former Mississippi State All-American, Stan Black of Madison, was killed after he stopped at the scene of a crash on I-55 north of the Canton exit.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad720-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad720" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad720",slotName:"wlbt/web/news/G2DIWSE7HBB6DEQBFC5MRBF7MQ",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="interstitial_link" class="card collection-item card-embedded-content"> <div class="card-content card-article"> <div class="element element-interstitial"> <p>[ <a href="http://www.wlbt.com/story/38956548/good-samaritan-former-msu-all-american-killed-in-madison-co-car-crash/"> 'Good Samaritan': Former MSU All-American killed in Madison Co. car crash</a> ] </p> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Black got out of his car to help the passenger of an SUV involved in the wreck and move sheet rock from the interstate.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>A woman driving a Kia could not stop her car in time and slammed into Black, killing him.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“Well, of course, people want to help, but you know, your safety when you want to help is pretty much your first priority," said Cpl. Kervin Stewart with the Mississippi Highway Patrol. “You know, you can’t help anybody if you’re hurt, but if you do that, take all the safety precautions you can. Pull over safely out the roadway, be aware of your surroundings, but also be aware that a lot of people probably aren’t paying attention to what’s going on ahead of them and you just have to watch out for them also.”</p> <div class="flex-container-column align-items-center hidden-sm spaced spaced-top spaced-sm"> <div id="ad307-sticky" class="flex-container-column "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad307" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad307",slotName:"wlbt/web/news",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Cpl. Stewart said the holiday season will bring on even greater challenges on the highways. Thanksgiving, he said, is the most traveled period in America and he urges all drivers to be extra cautious.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad648-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad648" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad648",slotName:"wlbt/web/news/G2DIWSE7HBB6DEQBFC5MRBF7MQ",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“Wear your safety belt. Don’t drink and drive. If you’re going to drink, have a designated driver," reminded Cpl. Stewart. "I mean, it’s that time of year again where people are gonna be celebrating and, of course, if you’re gonna be out celebrating, you know, just make sure you have some safety plans in place. There’re plenty of applications on your phone you can use now to get you to and from your location, plus make sure you have a designated driver.”</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>As for stopping at the scene of an accident to help, in some cases, it may be better to keep moving and let first responders do what they’re trained to do rather than risk even more tragedy.</p> </div> </div> <div data-type="text" class="card collection-item card-border-bottom card-border-bottom-thick card-border-bottom-dark"> <div class="card-content card-article"> <p><i>Copyright 2018 </i><a href="//www.wlbt.com"><i>WLBT</i></a><i>. All rights reserved.</i></p> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-outbrain" id="f79GaC1s7WCp9r"> <div id="outbrain-article-ad" class=""> <div class="OUTBRAIN" data-widget-id="AR_8" data-src="http://www.wlbt.com/2018/11/15/being-good-samaritan-highway-could-be-dangerous-even-deadly/" data-ob-template="raycom"> </div> <div class="OUTBRAIN" data-widget-id="AR_9" data-src="http://www.wlbt.com/2018/11/15/being-good-samaritan-highway-could-be-dangerous-even-deadly/" data-ob-template="raycom"> </div> </div> </div> </section> </div> <div class="pb-container"> </div> </article> <aside id="right-rail" class="col desktop-4 tablet-12 mobile-12 right-rail"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fVHFSu1s7WCp9r"> <div id="ad674-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad674" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad674",slotName:"wlbt/web/news",adType:"flex-cube",dimensions:"[[[300, 600], [300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"G2DIWSE7HBB6DEQBFC5MRBF7MQ"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> <div class="wrapper clearfix col desktop-12 tablet-12 mobile-12 pb-feature pb-layout-item pb-f-weather-forecast-box" id="fWbr8K1s7WCp9r"> <div class="invisible weather-gradient flex-grid color-white pb-weather night" id="weather-forecast-box" data-valid-content="true"> <div id="forecast-box-bg-wrapper" data-current-bg-image="night-partly-cloudy" data-default-location-code="USMS0175" class="weather-item flex pb-weather pb-forecast-box padded padded-md padded-top padded-bottom padded-right padded-left"> <div id="forecast-box-content"> <input type="hidden" id="forecast-box-zip-code" data-url="/pb/api/v2/render/feature/weather/forecast-box" data-feature-grouping=".pb-f-weather-forecast-box" data-website="wlbt" data-location-code="USMS0175" data-language="en" data-content-config-keys='Code,Language' data-content-config-values='USMS0175,en' data-custom-field-keys='spanish' data-custom-field-values=''/> <div class="col spaced spaced-top spaced-sm"> <div class="flex-container-row justify-center"> <div class="spaced spaced-right spaced-lg flex-container-row align-items-center"> <a href="http://www.wlbt.com/weather"> <img class="radar-image" src="//webpubcontent.raycommedia.com/wlbt/radar.jpg" width="100%"/> </a> </div> <div class="flex-container-column"> <div class="flex-container-row"> <div class="font-bold temp temp-lg weather-temp temp-lg-forecast-box" data-temp-f="29" data-temp-c="-2"> 29</div> <div class="icon spaced spaced-left spaced-md flex-container-row align-items-center"> <img width="40px" height="40px" src="/pb/resources/images/weather/weather-condition-icons/400x400/98_daily_forecast.png" alt="weather icon"/> </div> </div> <div class="spaced spaced-sm spaced-top text-align-center"> <div class="flex-container-column relative"> <div class="text-align-center"> <span class="location font-bold"> Currently in<br/>Jackson, MS</span> </div> </div> </div> <div class="flex-container-row spaced spaced-top spaced-md justify-center"> <a href="http://www.wlbt.com/weather"> <button class="weather uppercase button button-mini-radius button-transparent button-white-border color-white bold font-sm padded padded-xs padded-left padded-right padded-top padded-bottom"> Full Forecast</button> </a> </div> </div> </div> </div> </div> </div> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c0M8OPDs7WCp9r"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="flcThV1s7WCp9r"> <div class="flex-feature height-full"> <h3 class="bold"><span class="rectangle"></span> RECENT CONTENT</h3> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-58285" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2018/11/15/jpd-officers-now-equipped-with-body-cameras/"> <img class="width-full " alt="60 JPD officers now equipped with body cameras" src="http://www.wlbt.com/resizer/shHUsWv0iXOmncvMBe-ZqcZM08s=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/Z7HVWZPMIVEP3NZCUYI5RX3TAQ.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/15/jpd-officers-now-equipped-with-body-cameras/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; 60 JPD officers now equipped with body cameras</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">Police Chief James Davis hopes this will protect his officers in the future, and also show the full story of crime in the Capital City.</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Nick Ducote</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2018/11/14/dead-injured-after-tour-bus-overturns-slick-highway/"> <img class="width-full " alt="Victims identified after Tunica-bound tour bus overturns on slick Mississippi highway " src="http://www.wlbt.com/resizer/b1GI4hueuHl2lFrErh7hROewaWA=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/DQ3NSV7WVFBL3FLFSEKYDRBHQA.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/14/dead-injured-after-tour-bus-overturns-slick-highway/"> Victims identified after Tunica-bound tour bus overturns on slick Mississippi highway </a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">Two people are dead and 44 others are injured after a tour bus overturned in DeSoto County, Mississippi, about 40 miles south of Memphis.</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>WMCActionNews5.com Staff</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f0dGl5Us7WCp9r"> <div id="ad1149-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1149" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1149",slotName:"wlbt/web/news",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"G2DIWSE7HBB6DEQBFC5MRBF7MQ"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c0nuMc1s7WCp9r"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="f0rVQZOs7WCp9r"> <div class="flex-feature "> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-146648" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/11/14/crews-battle-deadly-camp-woolsey-fires-new-blaze-breaks-out-southern-california/"> <img class="width-full " alt="Firefighters begin to see progress against deadly California blazes, as death toll rises to 59" src="http://www.wlbt.com/resizer/kiAGGTpEzMec5CpiN4PeM6HR8Qo=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/T4H5LW6VKBCHZHJI2G3ZU7IH4A.JPG"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/14/crews-battle-deadly-camp-woolsey-fires-new-blaze-breaks-out-southern-california/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; Firefighters begin to see progress against deadly California blazes, as death toll rises to 59</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 2h at 8:43 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/11/15/campaigning-continues-with-days-until-senate-special-election-runoff/"> <img class="width-full " alt="Campaigning continues with 13 days until the Senate special election runoff" src="http://www.wlbt.com/resizer/bW3fOiDH_MWEZVZPwkTQIMQE2gQ=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/P27QWYNLAVCATJ4TBZHHNACCCA.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/15/campaigning-continues-with-days-until-senate-special-election-runoff/"> Campaigning continues with 13 days until the Senate special election runoff</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Courtney Ann Jackson</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 3h at 7:22 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/11/15/mississippi-delta-preps-winter-weather-november/"> <img class="width-full " alt="Mississippi Delta preps for winter weather in November" src="http://www.wlbt.com/resizer/2eaXyHfZqqtlALmlqrKvh6gi1Mc=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/YQ5SMEBMIRH5PNEP43IGJO5XH4.bmp"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/15/mississippi-delta-preps-winter-weather-november/"> Mississippi Delta preps for winter weather in November</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>David Kenney</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 3h at 7:14 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/11/15/local-shelters-rush-find-blankets-warm-clothing-homeless-after-sudden-plunge-temperatures/"> <img class="width-full " alt="Local shelters rush to find blankets and warm clothing for homeless after sudden plunge in temperatures " src="http://www.wlbt.com/resizer/OBhEiicXirE9oZvMZ_zdJT6g6Vc=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/7X74P7HZFJAODDUIFRHIPAR7BA.JPG"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/15/local-shelters-rush-find-blankets-warm-clothing-homeless-after-sudden-plunge-temperatures/"> Local shelters rush to find blankets and warm clothing for homeless after sudden plunge in temperatures </a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Roslyn Anderson</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 4h at 7:02 PM </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="pb-container"> </div> </aside> <div id="recirc" class="col desktop-12 tablet-12 mobile-12"> </div> </div> <section id="bottom" class="col desktop-12 tablet-12 mobile-12"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fAxTV22s7WCp9r"> <div id="ad469-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad469" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad469",slotName:"wlbt/web/news",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"G2DIWSE7HBB6DEQBFC5MRBF7MQ"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-footer" id="fwuHDX1s7WCp9r"> <footer class="card card-dark"> <div class="container"> <div class="container spaced spaced-sm spaced-left"> <div class="flex flex-container-column flex-tablet-row flex-desktop-row width-full color-white"> <div class="spaced spaced-right spaced-bottom spaced-xl"> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="http://www.wlbt.com"> <div class="logo logo-slim"></div> </a> </div> </div> <div class="spaced spaced-right spaced-xl footer-mission"> <p class="spaced spaced-bottom spaced-xs"> 715 South Jefferson Street<br/>Jackson, MS 39201<br/>(601)948-3333 </p> <a class="call-to-action uppercase color-white" href="http://www.wlbt.com/about-us/contact">Contact Us<br/>news@wlbt.com <i class="fa fa-caret-right" aria-hidden="true"></i></a> <div class="spaced spaced-top spaced-xl hidden-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/wlbt" class="color-white">WLBT FCC Public File</a></li> <li><a href="mailto:publicfile@wlbt.com" class="color-white">publicfile@wlbt.com<br/>(601) 948-3333</a></li> <li><a href="http://webpubcontent.raycommedia.com/wlbt/PDF/WLBTEEOReport2018.pdf" class="color-white">WLBT EEO Report</a></li> <li><a href="http://www.wlbt.com/story/19486847/closed-captioning-information/" class="color-white">WLBT Closed Captioning</a></li> <li><a href="http://publicfiles.fcc.gov/tv-profile/wdbd" class="color-white"><br/>WDBD FCC Public File</a></li> <li><a href="mailto:publicfile@fox40tv.com" class="color-white">publicfile@fox40tv.com<br/>(601) 948-3731</a></li> <li><a href="http://webpubcontent.raycommedia.com/wlbt/PDF/WDBDEEOReport2018.pdf" class="color-white">WDBD EEO Report</a></li> <li><a href="http://www.wlbt.com/story/22944005/wdbd-closed-captioning/" class="color-white">WDBD Closed Captioning</a></li> <li><a href="http://careers-raycommedia.icims.com/jobs/search?ss=1&searchLocation=-12808-Jackson" class="color-white"><br/>WLBT/WDBD Careers</a></li> <li><a href="http://www.wlbt.com/2018/08/29/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="http://www.wlbt.com/2018/08/29/terms-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="spaced spaced-top spaced-xl hidden-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/WLBT" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/WLBT3" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> <div class="spaced spaced-right spaced-xl visible-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/wlbt" class="color-white">WLBT FCC Public File</a></li> <li><a href="mailto:publicfile@wlbt.com" class="color-white">publicfile@wlbt.com<br/>(601) 948-3333</a></li> <li><a href="http://webpubcontent.raycommedia.com/wlbt/PDF/WLBTEEOReport2018.pdf" class="color-white">WLBT EEO Report</a></li> <li><a href="http://www.wlbt.com/story/19486847/closed-captioning-information/" class="color-white">WLBT Closed Captioning</a></li> <li><a href="http://publicfiles.fcc.gov/tv-profile/wdbd" class="color-white"><br/>WDBD FCC Public File</a></li> <li><a href="mailto:publicfile@fox40tv.com" class="color-white">publicfile@fox40tv.com<br/>(601) 948-3731</a></li> <li><a href="http://webpubcontent.raycommedia.com/wlbt/PDF/WDBDEEOReport2018.pdf" class="color-white">WDBD EEO Report</a></li> <li><a href="http://www.wlbt.com/story/22944005/wdbd-closed-captioning/" class="color-white">WDBD Closed Captioning</a></li> <li><a href="http://careers-raycommedia.icims.com/jobs/search?ss=1&searchLocation=-12808-Jackson" class="color-white"><br/>WLBT/WDBD Careers</a></li> <li><a href="http://www.wlbt.com/2018/08/29/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="http://www.wlbt.com/2018/08/29/terms-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="visible-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/WLBT" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/WLBT3" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> </div> </div> </footer> </div> <div class="pb-container"> </div> </section> </div> <script async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <script async src='/pb/gr/p/default/r0rrvMTr7WCp9r/render.js?v=36'></script>